マンガ制作ツール コミラボ ヘルプ:その他

マンガ制作ツール コミラボ ヘルプ:その他

その他機能について、ショートカットキー、FAQ

選択範囲について

画像編集をする際、特定の範囲だけを編集対象にしたい場合があります。
そういった時に、選択範囲機能をつけて、レイヤーを編集します。
デフォルトでは、選択範囲が全く無い状態になっています。選択範囲がない場合は、全領域が編集対象になります。また、選択範囲外のマスクされている部分は、半透明で色づけされています。
選択範囲を作りたい場合は、ツールウィンドウから、適切な選択範囲ツールを選択します。

<矩形選択>

マウスでドラッグした範囲を矩形選択します。

<楕円選択>

マウスでドラッグした範囲を楕円選択します。

<多角形選択>

マウスクリックで頂点を追加し、ダブルクリックで終点を決定し、多角形選択をします。

<投げなわ選択>

マウスでドラッグした範囲を選択します。

<自動選択>

クリック位置から指定輝度以内の閉領域を選択します。閾値は、レイヤーと表示画像を選べます。

<色域選択>

クリック位置から指定輝度以内の領域を選択します。

<選択ペン>

選択範囲をブラシのような感覚で追加できるツールです。

<選択消し>

選択範囲を消しゴムのような感覚で除外できるツールです。

選択範囲の新規作成・追加・削除

選択ツールで処理をすると、既存の領域は消え、新規領域がつくられます。
既存の領域に選択範囲を追加したい場合は、キーボードのショートカットを使います。

<何も押さないで選択>

新規範囲が作れらます

<Shiftを押しながら選択>

既存の選択範囲に追加されます

<Ctrlを押しながら選択>

既存の選択範囲から削除されます

表示について

画像を編集する際は、ドキュメントを拡大・縮小表示したり、表示位置を微調整します。
これらの操作は沢山の方法が用意されているので、一覧できるようにリストアップしておきます。
ご自分に合った方法を見つけてください。

表示位置の変更

・手のひらツールを選択し、ドキュメントの上でドラッグをする。
・スペースキーを押しながらドラッグをする。
・ナビゲータ上でドラッグして、表示の中心位置を指定する。

表示の拡大縮小

・マウスホイールの上下で拡大・縮小。
・Ctrl+Space+クリックで拡大表示。
・Ctrl+Alt+Space+クリックで縮小表示。
・Ctrl+プラスキー(+)で拡大表示、Ctrl+マイナスキー(-)で縮小表示。
・ナビゲータ上で右ドラッグ(上下方向)をする。

表示の回転

・手のひら回転ツールを選択し、ドキュメントの上でドラッグをする。
・<Space+Shiftキー>を押しながら、ドキュメントの上でドラッグをする。
・<Space+Altキー>を押しながら、ドキュメントの上でドラッグをする。
・<無変換キー>を押しながら、ドキュメントの上でドラッグをする。

表示の反転

・<↓(下)キー>を押すと表示状態が反転します。↑(上)キーで解除します。
・メインメニューの[表示][左右反転]で反転表示になります。

表示の回転・反転の解除

・<↑(上)キー>を押す。
・メインメニューの[表示][回転の終了]を選択する。
・<無変換キー>を押すと(押し離すと)回転状態がクリアされます(反転はそのまま)。

フィルタ一覧

フィルタ処理は、アクティブなビットマップレイヤーを対象に行われます。レイヤーの種類によっては、使えないフィルタがあります。
以下、各フィルタの特徴と用途を記します。

レベル補正

画像を、ある範囲の輝度から、ある範囲の輝度まで、再マッピングをするフィルタです。
画像の暗い部分 (127以下、など) を、輝度全体 (0~255) にマッピングすれば、暗部の画像が強調された画像になります。
デジカメで露出が足りなかった画像を補正する場合などに使います。

トーンカーブ

画像の入力と出力の関係を、頂点を右クリックで、その頂点を削除することができます。

チャンネルフィルタ

R,G,Bチャンネル別にフィルタリングできます。

色相

画像をHLS空間に変換し、色相や彩度を補正するフィルタです。
色味を大きく変えたい場合などに使います。彩度の低い、モノクロ系の画像には変化は少ないです。

カラーバランス

微妙な色味を調整するフィルタです。

ポスタリゼーション

画像の輝度の段階数を減らします(256段階から、4段階、32段階などに)。

ガウスぼかし

画像を大きくぼかすことができます。
(注)値を大きくするほど、処理に時間がかかります。

移動ぼかし

指定した方向に画像をぼかします。
(注)値を大きくするほど、処理に時間がかかります。

放射状ぼかし

指定位置を中心に、放射状に画像をぼかします。
中心から遠くなるほど、ぼかす量が大きくなります。
(注)値を大きくするほど、処理に時間がかかります。

モザイク

選択された範囲をモザイク処理します。マスク処理を指定できます。
<通常処理>マスク周辺のピクセルも、モザイクの大きさ・形状が保持されます。
<形状を優先>マスクのエッジ周辺では、モザイクがマスク形状によって切り取られます。

ノイズ

選択範囲にノイズを加えます。
カラーレイヤーの場合、不透明度は維持されます。したがって、透明な画像に対しては何も描画されません。

集中線

選択範囲を覆うような集中線を描画します。選択範囲が無い場合は画像全体が対象になります。
再描画に時間が掛かりそうな場合は、パラメータ変更時には簡易表示されます。

流線

選択範囲を覆うような流線 (並行線) を描画します。選択範囲が無い場合は画像全体が対象になります。
再描画に時間が掛かりそうな場合は、パラメータ変更時には簡易表示されます。

ウニフラッシュ

選択範囲を覆うようなウニフラッシュを描画します。選択範囲が無い場合は画像全体が対象になります。
再描画に時間が掛かりそうな場合は、パラメータ変更時には簡易表示されます。

コピー・切り取り・貼り付けについて

コピー

<ビットマップレイヤーの場合>

選択範囲がある場合、選択範囲を適用したデータが、各色深度(1/8/32bpp)で保存されます。
選択範囲がない場合は、レイヤー画像全体がコピーされます。

<ベクターレイヤーの場合>

専用の内部形式で、クリップボードにコピーされます。ベクターレイヤーに対して貼り付けができます。

切り取り

<ビットマップレイヤーの場合>

選択範囲がある場合のみ実行できます。選択範囲を適用したデータが、各色深度(1/8/32bpp)で保存されます。
選択範囲内はクリアされます。

<ベクターレイヤーの場合>

専用の内部形式で、クリップボードにコピーされます。
ベクターレイヤーに対して貼り付けた時に、コピーされた部分が削除されます。

貼り付け

<ビットマップレイヤーに対しての場合>

クリップボード内のデータを、新規レイヤーとして貼り付けます。
必要に応じて、下のレイヤーへの統合などの処理を行ってください。

<ベクターレイヤーの場合>

クリップボード内のデータを、「画像オブジェクト」として、ベクターレイヤー内に追加します。
追加できないデータだった(カラー画像以外)場合、ビットマップレイヤーに新規作成、貼り付けされます。

ラスタライズについて

ラスタライズについて

レイヤーの状態はそのままで、統合した画像を気軽に作りたい場合があります。そんな時に役立つのが、この「ラスタライズ」です。
メインメニューから[ファイル][ラスタライズ][新規画像に書き出す]を行うと、上記のダイアログが表示されます。

<色深度>では、出力する際の色深度を指定できます。カラーそのままなら、32bpp。グレースケール化したいなら、8bppを選びます。
8bppで出力をするとメモリ消費量も少なくなるので、モノクロ原稿の際は8bppで出力するのを強くお薦めします。

<レイヤーカラーを黒か白に強制する>をチェックすると、レイヤーのカラー情報が無視されます。
一時的に色をつけてレイヤー分けをして作業している場合、このチェックを行うと、「白」または「黒」、近いほうにレイヤーカラーが設定されます。
作業が終わった時に、いちいちレイヤーカラーを戻さずに済むので便利です。

<ハーフトーン情報を無視する>をチェックすると、ラスタライズ時に、8bppレイヤーのハーフトーン情報を無視してラスタライズします。
印刷用原稿、ウェブ用原稿など、使い分けたい時などに便利です。

環境設定ウィンドウ

環境設定ウィンドウ

[ファイル]->[環境設定]メニューから表示されるウィンドウです。

自動保存タブ

<自動サムネイル生成>

mdp形式で保存した際に、自動でサムネイルを生成する機能です。

<テキストの自動保存>

mdp形式で保存した際に、自動でベクターレイヤーのテキストオブジェクトの文字情報をテキスト形式で保存する機能です。

<自動バックアップ>

mdp形式で保存した際に、上書き前のファイルのバックアップを取っておく機能です。

ペンタブ

ペンタブ
<テールスイッチ>

ペンタブレットのテールスイッチの挙動を指定します。

ショートカットタブ

ショートカットタブ
<動作>

どの操作を実行したいか指定します。

<キー設定>

どのキー(+シフト状態)を押した場合に発動させたいか指定します。

<競合設定>

競合する設定を表示します。

ラベルタブ

ラベルタブ

ブラシ、パターン、パレットは、グループ分けできるのですが、その各グループに別名をつける事ができます。
ファイルシステム上の位置が変わるわけでなく、ウィンドウ上の表示が変わるだけです。

レイヤータブ

レイヤープロパティの、<名前>の右にある[>>]というボタンを押した際に出る候補を設定します。
面倒なレイヤー名設定を一発で行える機能です。

レイヤータブ
レイヤータブ

その他タブ

その他タブ
<枠線オブジェクトのマージン>

枠線オブジェクトのサイズを変更させた際に出る領域(コマ間隔を想定)を指定します。

<ブラシスナップ中はグリッドを表示しない>

そのままです。

<ナビゲータを常に高品質表示>

そのままです。

<ファイルのロック機構を有効にする>

mdp形式のファイルを編集中は、ロック制御用のファイルを生成し、他のユーザーが編集できないようにします。
他のユーザーも有効にしていないと意味がありません。

設定ファイルについて

アプリケーションの設定は、[ヘルプ]メニューの、[設定フォルダを開く]で表示されるフォルダに保存されます。
保存されるファイルは、

  • config.xml(ウィンドウの位置やサイズ、ツール設定などのコンフィグ情報)
  • style.xml(ドキュメントの新規作成ダイアログで使う、直近のスタイル設定)
  • shortcut.xml(ショートカット設定)
  • palette.xml(パレット情報/デフォルト)
  • paletteA.xml(セットA)
  • paletteB.xml(セットB)
  • paletteC.xml(セットC)
  • paletteD.xml(セットD)
  • paletteE.xml(セットE)
  • brush.xml(ブラシ情報/デフォルト)
  • brushA.xml(セットA)
  • brushB.xml(セットB)
  • brushC.xml(セットC)
  • brushD.xml(セットD)
  • brushE.xml(セットE)

です。

パターンの設定は"pattern"フォルダに保存されます。
セット"--"と"A~E"が、"pattern"フォルダの中の、"--"と"A"~"E"フォルダ内に保存されます。
表示用に自動生成されたデータが、フォルダ内の"loop""thumb"フォルダに保存されます。

  • "pattern"フォルダ
  • "--"フォルダ
  • "A"フォルダ
  • "B"フォルダ
  • "C"フォルダ
  • "D"フォルダ
  • "E"フォルダ

新規作成テンプレート(*.mdp)は、"template"フォルダに用意してください。

インストールしたブラシスクリプト(*.bs)は、"bs"フォルダに保存されています。

ショートカット一覧

コミラボでは、作業を便利にするショートカットが幾つか用意されています。
特に覚えておくと便利なショートカットには、★マークをつけてあります。

表示系
<Space+ドラッグ> 表示の移動★
<Space+Shift+ドラッグ> 表示の回転
<Space+Alt+ドラッグ> 表示の回転
<無変換+ドラッグ> 表示の回転
<←> 左に90度ずつ表示回転
<→> 右に90度ずつ表示回転
<Shift+←> 左に15度ずつ表示回転
<Shift+→> 右に15度ずつ表示回転
<<> 左に15度ずつ表示回転
<>> 右に15度ずつ表示回転
<無変換> 表示の回転の終了
<↓> 表示の左右反転★
<↑> 表示の左右反転・回転の解除★
<Control+Space+クリック> 表示の拡大★
<Control+Space+Alt+クリック> 表示の縮小★
<マウスのWheelUp(WheelDown)> 縮小表示(拡大表示)★
ブラシスナップ系
<1> ブラシスナップの解除
<2> ブラシの平行線スナップの開始
<3> ブラシの縦横方向スナップの開始
<4> ブラシの3Dスナップの開始
<5> ブラシの放射状スナップの開始
<6> ブラシの同心円スナップの開始
<7> ブラシの曲線スナップの開始
その他
<A+レイヤー画素をクリック> アクティブレイヤーを、クリックされた画素を含むレイヤーに変更
<Control+Alt+左右ドラッグ> ブラシサイズの変更★
<Tab> 一時的にウィンドウを非表示にする(元に戻す)
<C> ブラシの補正モードの切り替え(なし/弱/中/強)
<Z> 押したままにすると、一時的に消しゴムモードに(現在のブラシ設定・サイズのまま、一時的に消しゴムタイプに変化しています)
<D> 前景・背景色を初期化します(黒/白)
<X> 前景・背景色の交換
<Alt+クリック> カーソル上の色を取得します(スポイト)
<Shift+クリック> 直線を描画します(最終ブラシ描画位置から)
<[> 前のブラシを選択
<]> 次のブラシを選択

FAQ(困った時に)

Q.アプリケーションの起動に失敗します。

A.設定ファイル(config.xmlなど)を削除すると、起動できるかもしれません。設定ファイルは、[ヘルプ]メニューの「設定フォルダを開く」で見れます。

Q.タブレットを認識しません。

A.タブレットメーカーのサポートサイトから、最新のドライバをダウンロードして再度お試しください。

Q.タブレットや筆圧を認識しなくなる事があります。

A.いったんタブレットのペンを、認識範囲外のところに持っていき、再度範囲内に持ってくると認識することがあります。

Q.タブレットPCで上手く動作しません。

A.タブレットPCには未対応です。Wintabドライバを入れると上手く動くかもしれません。

Q.タブレット使用時、カーソル位置と描画位置がズレます。

A.タブレットドライバを再インストールしてみてください。それでもダメなら、[ファイル][タブレット設定][マウス座標を使う]をチェックしてください。

このページの TOP へ